Actualización: Error WHMCS CURL

WHMCS ha descubierto un problema en un paquete Curl EA4 anterior introducido en los servidores CentOS.

¡Actualizar!

ACTUALIZACIÓN: Según los informes, esto se solucionó en ea-libcurl-7.67.0-2.2.1por lo que ya no debería ser necesario bajar de categoría.

Versiones de trabajo:
* ea-libcurl-7.66.0-1.1.2.cpanel.x86_64
* ea-libcurl-7.67.0-2.2.1.cpanel.x86_64

Versión con errores:
*ea-libcurl-7.67.0-1.1.2.cpanel.x86_64

Según https://forums.cpanel.net/threads/cpanel-curl-update-breaks-whmcs-enom-module.663449/ puede ser necesario reiniciar PHP-FPM para aplicar los cambios a los binarios de PHP en ejecución.

Síntoma

Es posible que reciba el error que se muestra a continuación cuando intente realizar ciertas actividades en sistemas remotos, como intentar registrar un dominio a través de eNom, administrar un dominio u otras actividades de alojamiento relacionadas con las cuentas en su servidor.

Registrar Error
Error CURL: 56 – OpenSSL SSL_read: éxito

Porque

De acuerdo con la curl devs, este problema es causado por:

un aumento en la sensibilidad del error SSL_ERROR_SYSCALL de OpenSSL para que los cierres abruptos del servidor también se consideren errores.

https://lqwb.us/2QGVZCH

Evidentemente, cuando un servidor no envía un ‘punto de terminación de protocolo’ reconocido (por ejemplo, una longitud de contenido HTTP o un fragmento de longitud cero y un tráiler vacío), provocará un error si la conexión se cierra abruptamente. La ausencia de un punto de terminación de TLS (por ejemplo, una alerta close_notify) resaltará este problema y aumentará las posibilidades de que ocurra este error. Esta preocupación también puede afectar a versiones adicionales de CURL que utilizan llamadas al sistema API.

La actualización anterior del sistema a cURL 7.67 en EasyApache 4 versión 2019-11-20 incluye cambios que causaron este problema. El problema ha sido identificado por los desarrolladores de cURL y se abordará en las próximas actualizaciones.

Solución alterna

Para solucionar este problema ahora mismo, volver a una versión anterior de cURL (versión 7.66) resolverá el error:

[[email protected]]# yum downgrade ea-libcurl ea-libcurl-devel

También debemos tener en cuenta que el equipo de soporte técnico de WHMCS no puede ayudar con este problema ya que es el resultado de un error anterior en curl.

Puede monitorear esta situación visitando los siguientes enlaces para detalles completos:

Si tiene problemas para solucionar este problema, llámenos hoy al 800.580.4985 o abra una chat ¡o tiquete con nosotros para hablar con uno de nuestros administradores de sistemas expertos!

Related Posts