TrollInstaller2 使在運行 iOS 14.0-15.5 beta 4 的 arm64e 設備上安裝 TrollStore 變得容易

TrollStore 開發商 Opa334 在本週四晚上以 TrollInstaller2 的形式為潛在用戶發布了另一個免費贈品。

公佈通過推特星期四晚上,TrollInstaller2 是原始 TrollInstaller 的修訂版,支持所有版本的 iOS 和 iPadOS,從 14.0 到 15.4.1(或 15.5 beta 1 到 4)。 相比之下,最初的 TrollInstaller 只支持 iOS 和 iPadOS 15.0 到 15.1.1 的版本。

引用TrollInstaller 2 GitHub 頁面儘管該項目與 iOS 和 iPadOS 版本 14.0-15.4.1(以及 15.5 beta 1 到 4)兼容,但它目前僅適用於配備 A12-A15 (arm64e) 芯片的設備。 安裝過程需要一台 Mac,用戶必須能夠訪問 THEOS 和 iOS 14.5 SDK。

GitHub 頁面繼續列出以下要求和步驟:

Pwned IPA 構建(目前需要 Mac)(需要安裝 THEOS 和 14.5 sdk)

1)獲取“Apple Developer”IPA(此應用程序:https://apps.apple.com/de/app/apple-developer/id640199958(抱歉,德語鏈接,但你明白了)),你可以使用 Apple Configurator 來完成(在你的設備上安裝它兩次,當它給你一個它已經存在的錯誤時,從復制 IPA ~/Library/Group Containers/<some_uuid>.group.com.apple.configurator/Library/Caches/Assets/TemporaryItems/MobileApps 其他地方,然後取消安裝)。

二)放在_compile/target/Developer.ipa

3)從 Fugu14 存儲庫中獲取 pwnify_compiled (https://github.com/LinusHenze/Fugu14/blob/master/tools/pwnify_compiled), 使用 colayout( codesign -s - <path/to/pwnify_compiled> ) 並將其放入 _compile/pwnify_compiled

4)確保您已安裝 Procursus ldid 並將其添加到您的路徑中! (https://github.com/ProcursusTeam/ldid)

5)cd 進入 _compile 並運行 ./build_trollinstaller2.sh ( chmod +x ./build_trollinstaller2.sh 如果您收到權限錯誤)

6)稍等一下,當它完成時,會有一個 DeveloperInstaller.ipa 在_compile/exit

值得注意的是,這是第一個支持在 iOS 和 iPadOS 15.1.1 之前的任何固件上安裝 TrollStore 的官方 Opa334 項目。 雖然用戶最初可以使用 SSH Ramdisk 方法安裝更新的固件,但 TrollInstaller2 更易於使用,並且從長遠來看將使最終用戶更容易升級到更新版本的 TrollStore。

對於那些還不知道的人,TrollStore 是一個越獄應用程序,幾乎可以對任何 .ipa 文件進行永久簽名。 這個過程類似於側面安裝,除了用戶不必重新簽署他們安裝的應用程序,因為他們有永久簽名。

開發人員 opa334 不斷通過以下方式宣布新的更新 Twitter 但 iDB 將繼續讓我們的讀者了解最新進展,敬請關注!

相關文章